Stickies
« Windows 7 64 bit installation »

Welcome Guest. Please Login or Register.
Jul 23rd, 2017, 7:37pm


Click to go to the
Zhorn Software Web Site
Click to go to the
Knowledgebase

« Previous Topic | Next Topic »
Pages: 1 2  Notify Send Topic Print
 hotthread  Author  Topic: Windows 7 64 bit installation  (Read 6123 times)
John Smith
Full Member
ImageImageImage


member is offline

Avatar




PM

Gender: Male
Posts: 127
xx Windows 7 64 bit installation
« Thread started on: Nov 13th, 2011, 05:01am »

I have just installed Windows 7 64 bit (fully updated) and tried to run Bart version 3, freshly downloaded from http://www.zhornsoftware.co.uk/bart/bart3beta.zip

I get a message saying that "the application has failed to start because its side-by-side configuration is incorrect.

Version 2.16 plus will run but when I click File, Open, although I see a list of my .job files, only one of them will open. Four others don't open when selected - double click or from the Open button (different format because they were used under version 3?)

I have tried running Bart as administrator and also in compatibility mode, even back to Windows 98!

Prior to this with Windows 7 32 bit, Bart was faultless. I have a strong feeling I am missing something obvious...
User IP Logged

John Smith
John Smith
Full Member
ImageImageImage


member is offline

Avatar




PM

Gender: Male
Posts: 127
xx Re: Windows 7 64 bit installation
« Reply #1 on: Nov 15th, 2011, 03:09am »

Tiny update: the one file that would open in version 2.16 plus was an old one that had never been run under version 3. Those that had run under version 3 have of course got extra entries and not surprisingly won't run under version 2.16.

That part is solved but the rest remains; I cannot run version 3 in my new 64 bit Windows 7 installation.
User IP Logged

John Smith
John Smith
Full Member
ImageImageImage


member is offline

Avatar




PM

Gender: Male
Posts: 127
xx Re: Windows 7 64 bit installation
« Reply #2 on: Nov 15th, 2011, 03:18am »

OK I am safely locked up in my padded cell again. Today is the third Tuesday of the month and the Microsoft updates have just finished installing.

And Bart version 3 - the best yet - is working again.
User IP Logged

John Smith
Tom Revell
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 3542
xx Re: Windows 7 64 bit installation
« Reply #3 on: Nov 15th, 2011, 12:19pm »

When I decided to use VS2005 for Bart, I checked 2005, 2008 and 2010 for what their behaviour was under various releases of Windows. No-one likes to learn that they need to download more support files for an app.

VS2005 is old enough that this doesn't happen - the support files are already in Windows XP and 7.

However, I'd not thought to check 64-bit sad I was just able to reproduce what you saw. I wonder whether installing either this:

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=3387

or this:

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=21254

would also have solved it. Well, you're ok, I'll work on this with the next person who reports it I guess...

Tom
User IP Logged

John Smith
Full Member
ImageImageImage


member is offline

Avatar




PM

Gender: Male
Posts: 127
xx Re: Windows 7 64 bit installation
« Reply #4 on: Nov 16th, 2011, 02:22am »

Thanks for your reply - it was reassuring. Before posting I searched for the error message and at one point saw advice to run sxstrace. I did and from the result found a couple more terms to search on.

Everything pointed to the second link you gave and I did in fact run vcredist_64.exe. That in itself was not enough to make Bart 3 work.

There have been two later changes. The first is a red herring I am sure: I had a problem with a USB device and "uninstalled" all USB items from Device Manager and restarted. The second change was to apply the November updates from Microsoft. None seem likely, being mostly Office updates.

However, after that Bart 3 worked perfectly and continues to do so. I make a daily image of my pc so I am quite happy to try almost anything; I an always restore back to yesterday. If I can run any test that might assist, don't hesitate to ask.
User IP Logged

John Smith
Tom Revell
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 3542
xx Re: Windows 7 64 bit installation
« Reply #5 on: Nov 16th, 2011, 10:47am »

Thanks - I think I'll see whether this is a frequent thing first. There's no need to spend time investigating if it's only ever your machine, briefly, which showed the problem!

Tom
User IP Logged

John Smith
Full Member
ImageImageImage


member is offline

Avatar




PM

Gender: Male
Posts: 127
xx Re: Windows 7 64 bit installation
« Reply #6 on: Nov 18th, 2011, 11:39am »

Makes sense to me. I can't say for sure this is connected but I don't think I saw this before changing to 64 bit Windows 7:

After running Bart 3 I sometimes get informed there are errors but I don't see them in the log file. I saved the last log file which said there were 10 errors but a search for "error" revealed nothing (except 10 errors). How can I send this to you?

User IP Logged

John Smith
schmude
New Member
Image


member is offline

Avatar




PM

Gender: Male
Posts: 3
xx Re: Windows 7 64 bit installation
« Reply #7 on: Nov 23rd, 2011, 08:41am »

Hallo Tom,

I have a PC with XP SP3 (german), on which Bart 2.16plus run ok. When using Bart 3.0 beta1 I get an error and the software is not started. "Diese Anwendung konnte nicht gestartet werden, weil die Anwenungskonfiguration nicht korrekt ist. Zur Problembehebung sollten Sie die Anwendung neu installieren." This is german of course, but it is the same message as the one posted from John Smith. I don't have a 64bit system. Is there a software which is required to be installed additionally ?

Regards Stefan

When do you intend to finalize Bart ?
User IP Logged

Tom Revell
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 3542
xx Re: Windows 7 64 bit installation
« Reply #8 on: Nov 23rd, 2011, 11:38am »

Does this download not solve the problem - it's the 32-bit version of the support files:

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=3387

I'll finalise Bart 3 when these sort of teething problems are resolved, or known about, and I've also got a number of little tweaks and fixes I know about which need doing before it gets the final thumbs up.

Tom
User IP Logged

schmude
New Member
Image


member is offline

Avatar




PM

Gender: Male
Posts: 3
xx Re: Windows 7 64 bit installation
« Reply #9 on: Nov 23rd, 2011, 3:29pm »

Hi Tom,

sorry, the download (http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=3387) does not solve my problem (same error mesage).

Bart is the best and fastest Sync-Program I ever have used.
I hope you can help me and you release V3 asap.

Thanx Stefan
User IP Logged

John Smith
Full Member
ImageImageImage


member is offline

Avatar




PM

Gender: Male
Posts: 127
xx Re: Windows 7 64 bit installation
« Reply #10 on: Nov 24th, 2011, 04:15am »

Here's another tweak if you haven't already got it on your list: if I double click a job file, Bart 3 opens but with the default job loaded, no matter which job file I have clicked.

If I run Bart 3 from a batch file and add the -file switch, it opens with the name of the file in the title bar but no tasks are displayed in the upper pane. This also applies if I specify default.job in the batch file.
User IP Logged

John Smith
JohnPap
Cardinal Member
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 513
xx Re: Windows 7 64 bit installation
« Reply #11 on: Nov 29th, 2011, 11:59am »

Below you can see just one line from a series of similar lines contained in a DOS batch file that runs Bart 3. It runs on 32-bit Windows though.

Code:
M:\Bart_Job_Database\bart.exe -letter:M -logexclusions -file "M:\Bart_Job_Database\Backup_LOCAL_to_ELITE.job" 


The following notation is similar, however the 'start /wait' sequence prevents the second instance from running until you exit the first Bart instance; i.e. click the 'Exit' button.

Code:
start /wait M:\Bart_Job_Database\bart.exe -letter:M -logexclusions -file "M:\Bart_Job_Database\Backup_LOCAL_to_ELITE.job"
start /wait M:\Bart_Job_Database\bart.exe -letter:L -logexclusions -file "M:\Bart_Job_Database\Backup_LOCAL_to_ELITE.job" 


Regards,
John
User IP Logged

John Smith
Full Member
ImageImageImage


member is offline

Avatar




PM

Gender: Male
Posts: 127
xx Re: Windows 7 64 bit installation
« Reply #12 on: Dec 18th, 2011, 10:34am »

I am still getting from time to time a log that says there is an error or errors, in the summary that appears at the bottom of the detailed log, but there is no red entry in that log stating what the error or errors are.

I have saved a few such log files in case they are helpful.
User IP Logged

John Smith
jeffmcd17
New Member
Image


member is offline

Avatar




PM


Posts: 2
xx Re: Windows 7 64 bit installation
« Reply #13 on: Dec 25th, 2011, 5:42pm »

Hope this helps everyone getting this problem.

I had a fresh install of Win7 x64 that Bart 3 beta didn't work on, but 2.16 did.

I tried the above files, and they didn't do anything for me.

I noticed while installing my copy of Nero 10 that it installed two Visual C++ updates. I checked Bart3 Beta right after Nero installed these two updates and it worked.

Someone having this issue try one of the below links and see if it fixes it for you.

http://support.microsoft.com/kb/973544

and/or

http://www.microsoft.com/download/en/details.aspx?id=5582

Let us know if one of these works for you.
« Last Edit: Dec 25th, 2011, 5:43pm by jeffmcd17 » User IP Logged

schmude
New Member
Image


member is offline

Avatar




PM

Gender: Male
Posts: 3
xx Re: Windows 7 64 bit installation
« Reply #14 on: Dec 28th, 2011, 07:07am »

Hello everybody,

after installing
'Microsoft Visual C++ 2005 Redistributable Package (x86)'
http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=5638

Version: 8.0.50727.762
Date Published: 8/27/2007
Size: 2.6 MB
(you need exactly this version!)

bart 3.00 1 runs ok on my system (win7 sp1 32bit).

My problem is solved now.

Regards
Stefan
smiley
User IP Logged

Pages: 1 2  Notify Send Topic Print
« Previous Topic | Next Topic »

Donate $6.99 for 50,000 Ad-Free Pageviews!

| |

This forum powered for FREE by Conforums ©
Sign up for your own Free Message Board today!
Terms of Service | Privacy Policy | Conforums Support | Parental Controls