Stickies
« Stickies Search Not Working »

Welcome Guest. Please Login or Register.
Jun 29th, 2017, 04:09am


Click to go to the
Zhorn Software Web Site
Click to go to the
Knowledgebase

« Previous Topic | Next Topic »
Pages: 1  Notify Send Topic Print
 thread  Author  Topic: Stickies Search Not Working  (Read 480 times)
tmoca
New Member
Image


member is offline

Avatar




PM


Posts: 7
xx Stickies Search Not Working
« Thread started on: Feb 8th, 2017, 7:32pm »

Hello. Long time Stickies user here. I am having a problem with the Search Engine feature. I can add the search engines, but when highlighting text and choosing to search, it doesn't do anything. The browser does not open at all.

I am using version 9.0d
W7 64bit
I do NOT have IE installed....only Chrome.

Any ideas on how I can get this to work?

Also, if I have a url in a stickie and click it, it DOES open Chrome.
User IP Logged

Cynthia
Cardinal Member
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 539
xx Re: Stickies Search Not Working
« Reply #1 on: Feb 8th, 2017, 8:41pm »

So your hyperlinks work fine, but you cannot use your search engines?

Here is a knowledgebase article on search engines, which might be helpful.
http://www.zhornsoftware.co.uk/support/kb.pl?q=00011

Have you declared Chrome to be the default browser on your system?

Cynthia
User IP Logged

tmoca
New Member
Image


member is offline

Avatar




PM


Posts: 7
xx Re: Stickies Search Not Working
« Reply #2 on: Feb 9th, 2017, 06:00am »

on Feb 8th, 2017, 8:41pm, Cynthia wrote:
So your hyperlinks work fine, but you cannot use your search engines?

Here is a knowledgebase article on search engines, which might be helpful.
http://www.zhornsoftware.co.uk/support/kb.pl?q=00011

Have you declared Chrome to be the default browser on your system?

Cynthia


Yes that is correct. The default search engines didn't work. I tried removing and re-adding using that knowledge base...no dice

And yes, Chrome is the default browser...that is the only browser on this machine.

https://s28.postimg.org/aczr0mgot/2017_02_09_065318.jpg
User IP Logged

Cynthia
Cardinal Member
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 539
xx Re: Stickies Search Not Working
« Reply #3 on: Feb 9th, 2017, 2:26pm »

I see nothing about this in the help file, but try this. Make this change in Options. In the advanced tab of Options, slide logging to debug. Then highlight some text and try using one of your search engines. After the Chrome browser does not open, then put attention on stickies and open the stickies log file by pressing control-shift-g. After the log file opens, copy the text in the log file and paste it here at the forum.

Cynthia
« Last Edit: Feb 9th, 2017, 5:15pm by Cynthia » User IP Logged

tmoca
New Member
Image


member is offline

Avatar




PM


Posts: 7
xx Re: Stickies Search Not Working
« Reply #4 on: Feb 9th, 2017, 7:29pm »

on Feb 9th, 2017, 2:26pm, Cynthia wrote:
I see nothing about this in the help file, but try this. Make this change in Options. In the advanced tab of Options, slide logging to debug. Then highlight some text and try using one of your search engines. After the Chrome browser does not open, then put attention on stickies and open the stickies log file by pressing control-shift-g. After the log file opens, copy the text in the log file and paste it here at the forum.

Cynthia


Thanks for your help. Here is the log

2/9/2017 8:24 PM.36 SaveOptions started for 'C:\Users\Craig\AppData\Roaming\stickies\options.ini'
2/9/2017 8:24 PM.36 SaveOptions completed OK
2/9/2017 8:24 PM.49 Running: *"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe* *http://www.google.com/search?q=Radio%20Conscious*
User IP Logged

Cynthia
Cardinal Member
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 539
xx Re: Stickies Search Not Working
« Reply #5 on: Feb 9th, 2017, 7:47pm »

Now we wait for Stickies maestro, Tom Revell, to interpret and advise. Don't forget to slide logging back up to the top in the advanced tab of options.

Cynthia
User IP Logged

tmoca
New Member
Image


member is offline

Avatar




PM


Posts: 7
xx Re: Stickies Search Not Working
« Reply #6 on: Feb 9th, 2017, 7:48pm »

on Feb 9th, 2017, 7:47pm, Cynthia wrote:
Now we wait for Stickies maestro, Tom Revell, to interpret and advise. Don't forget to slide logging back up to the top in the advanced tab of options.

Cynthia


Already did. smiley Thanks again for your help...much appreciated.

User IP Logged

Tom Revell
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 3542
xx Re: Stickies Search Not Working
« Reply #7 on: Feb 10th, 2017, 1:24pm »

The strings between the asterisks show what Stickies passes to Windows to run the link.

The first string is:

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe

Note the mismatch in " characters - this is going to be the cause of the problem I suspect. Perhaps it's wrong in the registry somehow, perhaps Stickies is getting the value wrong.

Are you familiar with the registry? Can you browse to:

HKEY_CLASSES_ROOT\http\shell\open\command

What's in there (exactly!) in the Default key on the right hand side?

Tom
User IP Logged

tmoca
New Member
Image


member is offline

Avatar




PM


Posts: 7
xx Re: Stickies Search Not Working
« Reply #8 on: Feb 10th, 2017, 4:37pm »

I did edit this, because originally it said IE, which I do not have installed so originally, it was not working before the edit...obviously I edited it incorrectly as well.. what is the actual statement that should be there?

I am familiar with the registry...just let me know what should be there and I will try it.

I have tried with and without quotes...neither seems to work.

Thanks Tom!
User IP Logged

Cynthia
Cardinal Member
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 539
xx Re: Stickies Search Not Working
« Reply #9 on: Feb 10th, 2017, 5:01pm »

I also use Win 7 64bit.
After changing my default browser to Chrome, I notice that my hyperlinks work and so do my search engines.

After browsing in the registry to
HKEY_CLASSES_ROOT\http\shell\open\command
In the Default key, I see that the data type is REG_SZ, and the data item is
"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" -- "%1"

Cynthia
User IP Logged

tmoca
New Member
Image


member is offline

Avatar




PM


Posts: 7
xx Re: Stickies Search Not Working
« Reply #10 on: Feb 10th, 2017, 6:50pm »

I just tried changing my entry to what you posted Cynthia and no dice. I also just tried an uninstall and re-install of Stickies...same thing. sad
User IP Logged

Tom Revell
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 3542
xx Re: Stickies Search Not Working
« Reply #11 on: Feb 13th, 2017, 2:25pm »

What I have is slightly different:

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" %1

Perhaps try that?

Tom
User IP Logged

tmoca
New Member
Image


member is offline

Avatar




PM


Posts: 7
xx Re: Stickies Search Not Working
« Reply #12 on: Feb 13th, 2017, 3:23pm »

Wooowhooo!!!! That worked!

Thanks Tom!!!
User IP Logged

Pages: 1  Notify Send Topic Print
« Previous Topic | Next Topic »

Donate $6.99 for 50,000 Ad-Free Pageviews!

| |

This forum powered for FREE by Conforums ©
Sign up for your own Free Message Board today!
Terms of Service | Privacy Policy | Conforums Support | Parental Controls