Stickies
« Hyperlinks not copyable / usable »

Welcome Guest. Please Login or Register.
Feb 23rd, 2018, 3:52pm


Click for the

Zhorn Software Web Site

Search Knowledge Base:

Search:
All terms Any terms

« Previous Topic | Next Topic »
Pages: 1 2 3 4 5  Notify Send Topic Print
 veryhotthread  Author  Topic: Hyperlinks not copyable / usable  (Read 1143 times)
Cynthia
Cardinal Member
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 604
xx Re: Hyperlinks not copyable / usable
« Reply #30 on: Jan 25th, 2018, 4:00pm »

User Image

Voila,
Cynthia

Image courtesy of Graphics Mouse at FreeDigitalPhotos.net
« Last Edit: Jan 25th, 2018, 4:01pm by Cynthia » User IP Logged

eef
Full Member
ImageImageImage


member is offline

Avatar




PM


Posts: 53
xx Re: Hyperlinks not copyable / usable
« Reply #31 on: Jan 25th, 2018, 11:13pm »

https://i.imgur.com/n3oQMe8.png" alt="User Image" border="0">

Cynthia ,same image ( copied image from this page and uploaded to imgur again)

It seems when the link is from a secure site https:// is does not work undecided

update : just removing the "s" and it is displayed rolleyes

Thank you Cynthia for pointing the search for a solution in the right direction .Imgur also provides for a "linked" BBCode that contains the https:// and the http:// for the image.

« Last Edit: Jan 26th, 2018, 04:14am by eef » User IP Logged

Cynthia
Cardinal Member
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 604
xx Re: Hyperlinks not copyable / usable
« Reply #32 on: Jan 26th, 2018, 09:18am »

LadyLike, Iíve not lost sight of what this thread is really about - getting back the right-click option to copy a linkís address.

eef: Iíve pointed the search for a solution in the right direction?? Forgive my naivety, but how is that not a solution for code useful for putting images here at the forum? I donít understand its flaw.

Cynthia
User IP Logged

LadyLike
Junior Member
ImageImage


member is offline

Avatar




PM


Posts: 31
xx Re: Hyperlinks not copyable / usable
« Reply #33 on: Jan 26th, 2018, 11:09am »

Cynthia:
Indeed, there was a sudden image issue subtopic so I didn't reply in an effort to keep things organized.
If we can agree to get back to the original topic this would be much appreciated laugh
So yes, the right-click issue which Tom is, as I understand it, working on. Tom can you let me know where and how I can send the RTF file I saved from the sticky?
User IP Logged

eef
Full Member
ImageImageImage


member is offline

Avatar




PM


Posts: 53
xx Re: Hyperlinks not copyable / usable
« Reply #34 on: Jan 26th, 2018, 11:13am »

My bad for the confusing sentence.You pointed to the flaw that prevented me from uploading images to this forum.I had done it many times but it did not work anymore.

You showed an image with the BBCode you used also using Imgur and it worked!

The difference is the link protocol your image is http://i.imgur.com/H6h1bpG.png but the link i get from imgur is https://i.imgur.com/FfYeUd0.png and while this link works on other forums it does not on conforums.com huh

That is why i said you pointed me in the right direction your link is a http:// while the link i have is a secure https:// link the data is encrypted.

Imgur seems to provide both versions and with the same image link except for the protocol , i could just remove the "s" but still have a valid link.

This is the return info from Imgur after uploading it:
User Image

Best regards,

User IP Logged

Tom Revell
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 3602
xx Re: Hyperlinks not copyable / usable
« Reply #35 on: Jan 26th, 2018, 3:50pm »

I did just send you an email ... but perhaps I don't need that sample RTF anyway...

I opened up the source, and remembered that I'd already changed the way that the link displays to make it more reliable. While I was just there, I went back to look again at one of the problems I wasn't able to solve at the time - that of editing a friendly name link.

I had success, so please try this build:

http://www.zhornsoftware.co.uk/stickies/stickiesPlus.zip

Not only should it show the tooltip more reliably, but it should also let you right-click the link and get the Copy Link Address menu item ... and on top of that, choosing that menu item will actually let you edit the link (or copy it). I'll need to tidy that up for when this gets released, but for now, could you let me know how you get on with the above please?

Tom
User IP Logged

Cynthia
Cardinal Member
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 604
xx Re: Hyperlinks not copyable / usable
« Reply #36 on: Jan 26th, 2018, 3:55pm »

eef, I tinkered with it until I got something that worked! smiley
Not very scientific, I know.
I can confirm that the way I used to insert images through Imgur changed a few months ago.

Consider " https:// " contained in the link at Imgur. So the letter "s" means the data is encrypted? That's always preferable if possible. I certainly require it when I visit a financial institution's website for example. As you can see, I am nearly totally illiterate with respect to this.

Thanks for writing back!

LadyLike,
FYI, not that you need it now, but I believe that the RTF file for each sticky is found in the folder called "rtf" contained in the Stickies data folder. The RTF files are named by their unique ID number. To determine the ID number of a particular sticky, right-click the sticky's title bar and choose properties at the bottom of the menu; you'll see ID among a bunch of other properties of that sticky.

Cynthia
« Last Edit: Jan 26th, 2018, 6:26pm by Cynthia » User IP Logged

Tom Revell
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 3602
xx Re: Hyperlinks not copyable / usable
« Reply #37 on: Jan 27th, 2018, 10:49am »

You can also save any text note as RTF by pressing control-s, and changing the type to be RTF, which might be a little easier than grabbing the file from disk, although the end result will be the same.

In any case, LadyLike has sent me the file now ... although do let me know about that debug build please LadyLike.

Tom
User IP Logged

LadyLike
Junior Member
ImageImage


member is offline

Avatar




PM


Posts: 31
xx Re: Hyperlinks not copyable / usable
« Reply #38 on: Jan 27th, 2018, 11:08am »

Victory!!!
It works!!!
I just replaced stickies.exe by the one you sent.
I first renamed stickies.exe to 'stickies.exerrr' and then placed your build into the folder. And it works!
I will now try to create a sticky with lots of links in it smiley
Oh and yes I did use 'Ctr-s' to save as .rtf smiley
User IP Logged

LadyLike
Junior Member
ImageImage


member is offline

Avatar




PM


Posts: 31
xx Re: Hyperlinks not copyable / usable
« Reply #39 on: Jan 27th, 2018, 11:17am »

Tom: I have just added a few more links.
If I right-click on the link it has the option to copy the hyperlink address. YEAH!!!
I am so happy. I knew something was weird as the cursor was so jittery and the item disappeared from the menu but well, you never know right, it might have been WIndows10 weirdness. Thankfully all is resolved.

GOOD JOB!!! laugh laugh laugh
Thank you very much Tom!
User IP Logged

LadyLike
Junior Member
ImageImage


member is offline

Avatar




PM


Posts: 31
xx Re: Hyperlinks not copyable / usable
« Reply #40 on: Jan 27th, 2018, 11:25am »

Dear Tom.
I now actually chose 'Copy Link Address' but it gave me the 'Insert Link' window instead of simply copying it to the clipboard. I tried a few times but that's all that happens. I can't copy it to the clipboard and instead, have to reselect the entire link to copy it, then close the window...
User IP Logged

Cynthia
Cardinal Member
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 604
xx Re: Hyperlinks not copyable / usable
« Reply #41 on: Jan 27th, 2018, 11:56am »

I also tried the new build. The menu link "Copy link address" shows up more faithfully (although the cursor pointing at a link now has the amphetamine jitters). But when I click on copy link address, something unexpected happens.

When I inserted the link, I gave it the friendly name, "WaPo" with address being https://www.washingtonpost.com. As expected, a link was created with the name WaPo. But when I choose the menu item "copy link address", the Insert Link dialogue appears with -

Name
WaPoHYPERLINK "https://www.washingtonpost.com" WaPo

Address
https:///www.washingtonpost.com

Cynthia
User IP Logged

LadyLike
Junior Member
ImageImage


member is offline

Avatar




PM


Posts: 31
xx Re: Hyperlinks not copyable / usable
« Reply #42 on: Jan 27th, 2018, 12:05pm »

Yes, this is what I wrote.
The 'Edit Hyperlink' window appears instead of the link being copied to the clipboard.
The jitters have been discussed before too smiley
« Last Edit: Jan 27th, 2018, 12:05pm by LadyLike » User IP Logged

Tom Revell
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 3602
xx Re: Hyperlinks not copyable / usable
« Reply #43 on: Jan 30th, 2018, 4:12pm »

LadyLike: check back when I posted the link, that behaviour is to be expected smiley For now I needed to know whether the updated exe works to fix the missing menu item problem, which it does seem to. I don't need the RTF from you now thanks, it's not relevant to this issue.

I can put the debug code back so that it just copies the link again, but I'd like to do some troubleshooting of the new functionality first, with:

Cynthia: doing what you describe works for me, which is typical. Could you send me the RTF through please, or post it here, and I'll see whether it's different for me. In case you wanted to try the test, this is what a simple text sticky looks like under the hood - this is the RTF from a note with a WaPo link in it:

Quote:
{\rtf1\ansi\ansicpg1252\deff0\nouicompat\deflang2057{\fonttbl{\f0\fswiss\fprq2\fcharset0 Segoe UI;}}
{\colortbl ;\red0\green0\blue0;\red0\green0\blue255;\red0\green102\blue204;}
{\*\generator Riched20 10.0.16299}\viewkind4\uc1
\pard\tx720\tx1440\tx2160\tx2880\tx3600\tx4320\tx5040\tx5760\tx6480\tx7200
\tx7920\tx8640\tx9360\tx10080\tx10800\tx11520\tx12240\tx12960\tx13680
\tx14400\tx15120\tx15840\tx16560\tx17280\tx18000\tx18720
\tx19440\tx20160\tx20880\tx21600\tx22320\tx23040
{\cf1\f0\fs20{\field{\*\fldinst{HYPERLINK "https://www.washingtonpost.com" }}{\fldrslt{\ul\cf2\cf3\ul WaPo}}}}\f0\fs20\par
}


You can see that the code isn't pulling the right part of the link from the encoded RTF, which is a shame, and that's why I used a MS library to do that work as I hoped they'd have got it right smiley

Tom
User IP Logged

LadyLike
Junior Member
ImageImage


member is offline

Avatar




PM


Posts: 31
xx Re: Hyperlinks not copyable / usable
« Reply #44 on: Jan 30th, 2018, 6:38pm »

I see the code, Tom, thank you.
And yes I read what you wrote but I simply assumed it would now be different, that the new build would fix it smiley

I am happy to see Cynthia too has the jittery stickies, the more the better since it hopefully will help finding the solution.

I am very curious about the solution, clearly something is strange.
I don't know this code, if it were CSS I would think something is closed too often cheesy so I am so sorry I can't be of help here! But I would like to be, so let me know what I can do, I would be glad to help.

Good to know there were no errors in my sticky!
User IP Logged

Pages: 1 2 3 4 5  Notify Send Topic Print
« Previous Topic | Next Topic »

Donate $6.99 for 50,000 Ad-Free Pageviews!

| |

This forum powered for FREE by Conforums ©
Sign up for your own Free Message Board today!
Terms of Service | Privacy Policy | Conforums Support | Parental Controls