Stickies
« Phantom errors »

Welcome Guest. Please Login or Register.
May 29th, 2017, 10:41pm


Click to go to the
Zhorn Software Web Site
Click to go to the
Knowledgebase

« Previous Topic | Next Topic »
Pages: 1 2  Notify Send Topic Print
 hotthread  Author  Topic: Phantom errors  (Read 2591 times)
John Smith
Full Member
ImageImageImage


member is offline

Avatar




PM

Gender: Male
Posts: 127
xx Phantom errors
« Thread started on: Jan 27th, 2012, 03:10am »

Bart v3.00 beta 1 - Windows 7 64 bit

From time to time the summary after running Bart declares an error, shown in red. I open the detailed log but there is no error listed. I have several logs saved if they would help. (If so, how do I post them? They are saved as html files.)

This phantom error is most likely to appear when I use Bart to back up to an external disk but has happened when backing up only to internal disks.
User IP Logged

John Smith
Tom Revell
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 3540
xx Re: Phantom errors
« Reply #1 on: Jan 27th, 2012, 11:47am »

I spotted something which did that when I revisited the code a few weeks back, although I forget what it was now.

Does beta 2 do the same thing please?

Tom
User IP Logged

John Smith
Full Member
ImageImageImage


member is offline

Avatar




PM

Gender: Male
Posts: 127
xx Re: Phantom errors
« Reply #2 on: Jan 27th, 2012, 12:15pm »

I have downloaded 3.00 beta 2 and will let you know if this happens or not.

The revised layout showing the categories and colours is spot on, much more visible and clear - thanks for that.
User IP Logged

John Smith
JohnPap
Cardinal Member
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 513
xx Re: Phantom errors
« Reply #3 on: Jan 31st, 2012, 08:49am »

I have been using 3.00 beta 2 for almost 10 days now and have not noticed any phantom errors in two environments (home and office).

Regards,
John
User IP Logged

Simon Reed
New Member
Image


member is offline

Avatar




PM

Gender: Female
Posts: 1
xx Re: Phantom errors
« Reply #4 on: Apr 16th, 2012, 07:13am »

What is a phantom error? I also using 3.00 beta but not getting any kind of error in it.
User IP Logged


tribulus terrestris
John Smith
Full Member
ImageImageImage


member is offline

Avatar




PM

Gender: Male
Posts: 127
xx Re: Phantom errors
« Reply #5 on: Apr 16th, 2012, 07:32am »

Simon - That looks like good news. In an earlier version of Bart, I sometimes saw that it reported errors in the summary, but none were listed in the detailed log.

Version 3.00 beta 2 seems to have sorted the issue and I no longer get reports of errors that aren't there.

Bart v.3.00 beta 2 does report errors that are real, both in the summary and in the detailed log, so is working as it should.
User IP Logged

John Smith
txntv
New Member
Image


member is offline

Avatar




PM


Posts: 13
xx Re: Phantom errors
« Reply #6 on: Apr 21st, 2012, 4:14pm »

I am getting errors again. I tried deleting the backup and creating a new job. It gave me a windows error. Ran it twice ... same thing.

It stopped in the middle of copying .lua files.

Here's the error report:

<?xml version="1.0" encoding="UTF-16"?>
<grinATABASE>
<EXE NAME="bartDebug.exe" FILTER="GRABMI_FILTER_PRIVACY">
<MATCHING_FILE NAME="bartDebug.exe" SIZE="212992" CHECKSUM="0xF74B354B" BIN_FILE_VERSION="3.0.0.0" BIN_PRODUCT_VERSION="3.0.0.0" PRODUCT_VERSION="3, 0, 0, 0" FILE_DESCRIPTION="Bart - sync backup tool" COMPANY_NAME="Zhorn Software" PRODUCT_NAME="Bart" FILE_VERSION="3, 0, 0, 0" ORIGINAL_FILENAME="bart.exe" INTERNAL_NAME="bart" LEGAL_COPYRIGHT="Copyright (C) 2011" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x3D51E" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="3.0.0.0" UPTO_BIN_PRODUCT_VERSION="3.0.0.0" LINK_DATE="03/25/2012 14:22:56" UPTO_LINK_DATE="03/25/2012 14:22:56" VER_LANGUAGE="English (United States) [0x409]" />
</EXE>
<EXE NAME="MSVCR80.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
<MATCHING_FILE NAME="msvcr80.dll" SIZE="632656" CHECKSUM="0x47E3D63C" BIN_FILE_VERSION="8.0.50727.6195" BIN_PRODUCT_VERSION="8.0.50727.6195" PRODUCT_VERSION="8.00.50727.6195" FILE_DESCRIPTION="Microsoft® C Runtime Library" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Visual Studio® 2005" FILE_VERSION="8.00.50727.6195" ORIGINAL_FILENAME="MSVCR80.DLL" INTERNAL_NAME="MSVCR80.DLL" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xA071F" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="8.0.50727.6195" UPTO_BIN_PRODUCT_VERSION="8.0.50727.6195" LINK_DATE="05/14/2011 01:33:39" UPTO_LINK_DATE="05/14/2011 01:33:39" VER_LANGUAGE="English (United States) [0x409]" />
</EXE>
<EXE NAME="kernel32.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
<MATCHING_FILE NAME="kernel32.dll" SIZE="989696" CHECKSUM="0x2D998938" BIN_FILE_VERSION="5.1.2600.5781" BIN_PRODUCT_VERSION="5.1.2600.5781" PRODUCT_VERSION="5.1.2600.5781" FILE_DESCRIPTION="Windows NT BASE API Client DLL" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Windows® Operating System" FILE_VERSION="5.1.2600.5781 (xpsp_sp3_gdr.090321-1317)" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xFE572" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.5781" UPTO_BIN_PRODUCT_VERSION="5.1.2600.5781" LINK_DATE="03/21/2009 14:06:58" UPTO_LINK_DATE="03/21/2009 14:06:58" VER_LANGUAGE="English (United States) [0x409]" />
</EXE>
</DATABASE>
User IP Logged

Tom Revell
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 3540
xx Re: Phantom errors
« Reply #7 on: Apr 22nd, 2012, 4:43pm »

Could you download and try the file at:

http://www.zhornsoftware.co.uk/bart/bartDebug.zip

It will produce a very detailed log file as it runs, and when you experience the crash, could you open the file and look at what the last line is please?

Thanks,

Tom
User IP Logged

txntv
New Member
Image


member is offline

Avatar




PM


Posts: 13
xx Re: Phantom errors
« Reply #8 on: May 9th, 2012, 6:43pm »

Last file in debug.log was just a .jpg file.
User IP Logged

Tom Revell
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 3540
xx Re: Phantom errors
« Reply #9 on: May 10th, 2012, 11:48am »

If you re-run the task, does it always crash on the same file?

Tom
User IP Logged

txntv
New Member
Image


member is offline

Avatar




PM


Posts: 13
xx Re: Phantom errors
« Reply #10 on: May 10th, 2012, 12:05pm »

No. Ran it five times. Even tried running one job. And then the other job (I have two jobs). Doesn't last long before BART shuts down.

It also sets off a Microsoft error message. Here's the info:

<?xml version="1.0" encoding="UTF-16"?>
<DATABASE>
<EXE NAME="bartDebug.exe" FILTER="GRABMI_FILTER_PRIVACY">
<MATCHING_FILE NAME="bartDebug.exe" SIZE="212992" CHECKSUM="0xF74B354B" BIN_FILE_VERSION="3.0.0.0" BIN_PRODUCT_VERSION="3.0.0.0" PRODUCT_VERSION="3, 0, 0, 0" FILE_DESCRIPTION="Bart - sync backup tool" COMPANY_NAME="Zhorn Software" PRODUCT_NAME="Bart" FILE_VERSION="3, 0, 0, 0" ORIGINAL_FILENAME="bart.exe" INTERNAL_NAME="bart" LEGAL_COPYRIGHT="Copyright (C) 2011" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x3D51E" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="3.0.0.0" UPTO_BIN_PRODUCT_VERSION="3.0.0.0" LINK_DATE="03/25/2012 14:22:56" UPTO_LINK_DATE="03/25/2012 14:22:56" VER_LANGUAGE="English (United States) [0x409]" />
</EXE>
<EXE NAME="MSVCR80.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
<MATCHING_FILE NAME="msvcr80.dll" SIZE="632656" CHECKSUM="0x47E3D63C" BIN_FILE_VERSION="8.0.50727.6195" BIN_PRODUCT_VERSION="8.0.50727.6195" PRODUCT_VERSION="8.00.50727.6195" FILE_DESCRIPTION="Microsoft® C Runtime Library" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Visual Studio® 2005" FILE_VERSION="8.00.50727.6195" ORIGINAL_FILENAME="MSVCR80.DLL" INTERNAL_NAME="MSVCR80.DLL" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xA071F" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="8.0.50727.6195" UPTO_BIN_PRODUCT_VERSION="8.0.50727.6195" LINK_DATE="05/14/2011 01:33:39" UPTO_LINK_DATE="05/14/2011 01:33:39" VER_LANGUAGE="English (United States) [0x409]" />
</EXE>
<EXE NAME="kernel32.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
<MATCHING_FILE NAME="kernel32.dll" SIZE="989696" CHECKSUM="0x2D998938" BIN_FILE_VERSION="5.1.2600.5781" BIN_PRODUCT_VERSION="5.1.2600.5781" PRODUCT_VERSION="5.1.2600.5781" FILE_DESCRIPTION="Windows NT BASE API Client DLL" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Windows® Operating System" FILE_VERSION="5.1.2600.5781 (xpsp_sp3_gdr.090321-1317)" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xFE572" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.5781" UPTO_BIN_PRODUCT_VERSION="5.1.2600.5781" LINK_DATE="03/21/2009 14:06:58" UPTO_LINK_DATE="03/21/2009 14:06:58" VER_LANGUAGE="English (United States) [0x409]" />
</EXE>
</DATABASE>
User IP Logged

Tom Revell
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 3540
xx Re: Phantom errors
« Reply #11 on: May 13th, 2012, 09:04am »

Is there anything common about the final file which is written to the log file when the crash happens?

The type or the contents of the file won't be relevant, as Bart doesn't care about either of those, but a crash must be happening either in scanning a directory for file details, or perhaps as the file is opened?

If you add the file or the directory in which the file is located, to the exclusion list, does that help Bart get past it? Perhaps all the files which get listed last are in one directory tree?

Tom
User IP Logged

txntv
New Member
Image


member is offline

Avatar




PM


Posts: 13
xx Re: Phantom errors
« Reply #12 on: May 14th, 2012, 08:16am »

Nothing unusual. File and folder changes every time.
User IP Logged

Tom Revell
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM

Gender: Male
Posts: 3540
xx Re: Phantom errors
« Reply #13 on: May 14th, 2012, 1:25pm »

It looks from the log you've posted, that there is a little newer build than you're using - could you try with the latest beta from the site please, as I might have tracked this down already?

Tom
User IP Logged

Alex68
New Member
Image


member is offline

Avatar




PM


Posts: 3
xx Re: Phantom errors
« Reply #14 on: Sep 5th, 2012, 2:38pm »

With v3.0b5 I'm getting today in the summary 1 skipped, but in the log.html and the debug.log it is not listed.

Still somewhere an error in the code?
User IP Logged

Pages: 1 2  Notify Send Topic Print
« Previous Topic | Next Topic »

Donate $6.99 for 50,000 Ad-Free Pageviews!


This forum powered for FREE by Conforums ©
Sign up for your own Free Message Board today!
Terms of Service | Privacy Policy | Conforums Support | Parental Controls